Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
 Welcome to our latest new user Brizio ! (Registered 2017-08-20) You are not logged in 
CSDb User Forums


Forums > C64 Composing > Sid Wizard conversion woes
2016-06-19 11:38
Ray Manta

Registered: Jun 2014
Posts: 3
Sid Wizard conversion woes

Any Sid Wizard users have tips on weird behaviour when converting SWM file to SID?

The tune plays perfect in normal feature set boot of SID wizard but on conversion the resulting SID plays as silence then garbled notes!

The SID file is automatically renamed to "song.sid.prg" by stupid OSX on my mac - so all I can think is that by manually changing to file extension to "song.sid" something is being altered with the file?
2016-06-20 13:56
Frantic

Registered: Mar 2003
Posts: 1304
Quote:
The SID file is automatically renamed to "song.sid.prg" by stupid OSX on my mac


That sounds odd to me. As far as I am aware, OS X doesn't automatically rename any files, so this indicates to me that there is some kind of misunderstanding of what happens involved in the problem. ...but I'm no Sid Wizard user so I can't really say/help more than that.
2016-06-20 14:30
Linus

Registered: Jun 2004
Posts: 559
I am very sure it's not OSX that is renaming the file.

No Sid Wizard user either but I assume you're exporting to a native .prg rather than the sidplay format (.sid).
2016-06-21 02:26
Ray Manta

Registered: Jun 2014
Posts: 3
Quote: I am very sure it's not OSX that is renaming the file.

No Sid Wizard user either but I assume you're exporting to a native .prg rather than the sidplay format (.sid).


Hmm no just exporting as seq/sid and the resultant file always has a .prg at the end - but ordinarily any SID I convert from a SWM song file has to be renamed to just .SID and then it plays 100% fine in playsid / VLC - Hermit is now investigating so all is good!
2016-06-21 17:26
Merman

Registered: Dec 2002
Posts: 137
Just a thought.
On other editors I had problems if there was a blank instrument.
So, for example, I had used instruments 1-4, 5 was blank and then 6 onwards were used.

When the tune was compiled/saved, it would fail to work.
2016-06-22 02:52
Ray Manta

Registered: Jun 2014
Posts: 3
Quote: Just a thought.
On other editors I had problems if there was a blank instrument.
So, for example, I had used instruments 1-4, 5 was blank and then 6 onwards were used.

When the tune was compiled/saved, it would fail to work.


Thanks Merman - I am quite sure this was the problem - there was an instrument in slot01 that was perhaps setting the filter to nothing :)
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
Ant
moh/Fairlight
Compyx/Focus
hedning/G★P
Stainless Steel/F4CG
Alakran_64
Guests online: 58
Top Demos
1 Uncensored  (9.7)
2 Edge of Disgrace  (9.7)
3 Coma Light 13  (9.6)
4 The Shores of Reflec..  (9.6)
5 Lunatico  (9.6)
6 Comaland 100%  (9.5)
7 Incoherent Nightmare  (9.5)
8 Wonderland XII  (9.5)
9 Comaland  (9.5)
10 Wonderland XIII  (9.5)
Top onefile Demos
1 Veterans of Style  (9.5)
2 Dawnfall V1.1  (9.5)
3 Daah, Those Acid Pil..  (9.5)
4 Treu Love [reu]  (9.4)
5 Dawnfall  (9.3)
6 SidRok  (9.3)
7 F1 Evolution  (9.3)
8 One-Der  (9.2)
9 Tunnel Vision  (9.2)
10 Game of Thrones [2sid]  (9.1)
Top Groups
1 Pond  (10)
2 Booze Design  (9.4)
3 Censor Design  (9.4)
4 Oxyron  (9.4)
5 Crest  (9.3)
Top Webmasters
1 Slaygon  (9.6)
2 Perff  (9.6)
3 Morpheus  (9.5)
4 Sabbi  (9.4)
5 CreaMD  (9.3)

Home - Disclaimer
Copyright © No Name 2001-2017
Page generated in: 0.152 sec.