Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
You are not logged in 
CSDb User Forums


Forums > CSDb Discussions > SIDFX on Sidplay64
2017-05-08 23:08
6R6

Registered: Feb 2002
Posts: 221
SIDFX on Sidplay64

Hello users,
For anyone interested - I have implemented SIDFX
support in the latest Sidplay64 beta available at:

https://sourceforge.net/projects/sidplay64/

I have only tested it with the 1541u2, and it works great.

I welcome any feedback here on how it works with other devices
before I release it.
 
... 10 posts hidden. Click here to view all posts....
 
2017-05-13 18:15
6R6

Registered: Feb 2002
Posts: 221
Ok, new version beta 2 up on sourceforge.
Check it to see if it detects sid#1 and sid# correctly.
It doesnt matter what sid# port you have your sids in.
Just make sure you got TWO. :)
2017-05-14 12:11
fenz

Registered: Jul 2002
Posts: 14
Still plays with the wrong SID here (build date 13.05)

The SID selector switch is set in the middle position, and the second switch set at Stereo D400/D420. SIDFX config tool detects SID1=8580, SID2=6581.

Could you display the model/slot of the detected SIDs in the startup screen perhaps?
2017-05-14 13:17
6R6

Registered: Feb 2002
Posts: 221
My sidfx switch 2 is set to center position. And configured to be in Mono.

Dont know if that has to do with anything.
2017-05-14 14:00
fenz

Registered: Jul 2002
Posts: 14
Ok, set SW#2 to mono now, but didn't fix it.
2017-05-14 17:16
Mr Ammo

Registered: Oct 2002
Posts: 59
I use the same config as GRG, meaning: 6581 == SID1 and 8580 == SID2. But when I change it to Fenz's config (physically switching the SIDs),I see the same symptoms as Fenz describes.

It almost seems like something is hardcoded to always play 6581 tunes in SID1 and 8580 tunes in SID2.

It's weird, the least to say. I have switched back to my old config since that works with SP64.
2017-05-14 20:01
6R6

Registered: Feb 2002
Posts: 221
Ah, crap, ofcourse. It's another bug in my code when checking for unknown or faulty sid's that causes this.. when these two states are recognized it reverts to recommended sidfx setup which is 6581 in #1 and 8580 in #2.
2017-05-14 22:55
6R6

Registered: Feb 2002
Posts: 221
1,2 and 3.. Try again. Check beta 3.
2017-05-15 15:44
fenz

Registered: Jul 2002
Posts: 14
Good job, Beta 3 works! :)
Mr Ammo nice of you taking time to reproduce the bug.
2017-05-15 18:20
6R6

Registered: Feb 2002
Posts: 221
Marvellous. :)

Anyone with the sidfx card who gets a "sidfx card not found" message ?
2017-05-15 21:53
Mr Ammo

Registered: Oct 2002
Posts: 59
Yes, I had that 'sidfx card not found' a few times. I have not yet tried to reproduce this.
Previous - 1 | 2 - Next
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
Knut Clausen/SHAPE
Style/Chrome
Marvin/DPS
elkmoose
Guests online: 42
Top Demos
1 Uncensored  (9.7)
2 Edge of Disgrace  (9.7)
3 The Shores of Reflec..  (9.6)
4 Coma Light 13  (9.6)
5 Lunatico  (9.6)
6 Comaland 100%  (9.6)
7 Incoherent Nightmare  (9.5)
8 Wonderland XII  (9.5)
9 Comaland  (9.5)
10 Wonderland XIII  (9.5)
Top onefile Demos
1 Dawnfall V1.1  (9.5)
2 SidRok  (9.5)
3 Daah, Those Acid Pil..  (9.5)
4 Treu Love [reu]  (9.4)
5 Tunnel Vision  (9.3)
6 Dawnfall  (9.3)
7 One-Der  (9.2)
8 Hardware Accelerated..  (9.2)
9 Globe 2016 [reu]  (9.2)
10 Safe VSP  (9.1)
Top Groups
1 Booze Design  (9.4)
2 Oxyron  (9.4)
3 Censor Design  (9.3)
4 Crest  (9.3)
5 Camelot  (9.2)
Top Diskmag Editors
1 Jazzcat  (9.5)
2 Peter  (9.4)
3 Newscopy  (9.4)
4 Remix  (9.3)
5 Tadpole  (9.3)

Home - Disclaimer
Copyright © No Name 2001-2017
Page generated in: 0.145 sec.