Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
 Welcome to our latest new user Brizio ! (Registered 2017-08-20) You are not logged in 
CSDb User Forums


Forums > CSDb Discussions > WinVice 3.1 speed/performance on Ultrabooks?
2017-05-12 11:29
dano

Registered: Jul 2004
Posts: 105
WinVice 3.1 speed/performance on Ultrabooks?

Currently i am coding on an Asus UX32VD Ultrabook (which should have some like an Intel Core i7-3517U 1.9 GHz in it). As of WinVice3.1 using x64 with FastSid does not work correctly anymore. Visuals yes, but Sound sometimes totally goes south (no filters and such).

From the Vice people i was told to use ReSid as FastSid is not supported anymore.

Now my problems start: With using ReSid WinVice drops to like 24fps on my system. Using x64sc with Resid gives me like 8fps.

Looking at procmon it seems like one core is maxed out as CPU load never goes over 24% (the graphs show a different picture as none seems to be properly used).

My workhorse laptop at the office can run x64+resid nicely and properly, but okay it got way more power than my ultrabook will have.

Somehow i got the feeling that my system (Win10 Creators) is not really working properly anymore.

That's why i am asking here.. Any of you guys got a laptop compareable to mine and how's WinVice working on your system? Or what are the general performance reports for WinVice3.1?

Before i go into the ordeal of doing a complete re-install i would like to hear what other experience with WinVice currently. If it's problem on my side, or if it's just how well WinVice works on lower spec (sort of) laptops..
 
... 51 posts hidden. Click here to view all posts....
 
2017-05-16 13:17
dano

Registered: Jul 2004
Posts: 105
@Slajerek: can't wait for the release. your debugger got SO SO vital to my development cycle.

@Compyx: thanks for info, will give it a try. as dennis told me you said that FastSID won't be supported anymore. it's strange that WinVice3.1 sounds worse there with some of our tunes than i think 2.4 did. Always used FastSID while working on Reluge. And Tobias' latest 2 tunes sound like
utter crap on FastSID now.
Tobias told me to use a filter bias auf -2500 which is better to his ears than the default +500.

@Pantaloon: i am completely with you there. Sometimes we need to warp to certain locations and points in our products.

Getting a little offtopic here, but 2 things i noticed while dev'ing the last months:

- Sometimes Vice doesn't autostart the file it's given upon starting. Closing and redoing the Compile+Start solves this usually latest after like 2 tries.

- On Windows sometimes the Mousepointer gets hooked/invisible and you can't Mouse-Interact with Vice anymore (f.e. moving the window). Only Solution until now was to delete the config file and re-set all my custom settings (like debug-borders).

Coming back to my problem i usually notice that the Vice Display FPS slow down the more is happening on screen. Frankly speaking screen action should not have effect on Vice Perfomance?! Having stuff like flashing/debug Bordercolors makes Vice drop in FPS like hell.
2017-05-16 14:01
Groepaz

Registered: Dec 2001
Posts: 8120
Quote:
Turn off sound for real or tune back resampling to "fast". Then likely you'll get much better performance for testing stuff in warp.

...and it also _does_ effect acuracy of the emulation. no not just in terms of output - actual test programs will then fail. and thats why the default was changed.

dano: of course when more things happen, more CPU is used. thats why comparing warp speeds in the basic startup screen is a silly exercise :)
2017-05-16 14:25
Raf

Registered: Nov 2003
Posts: 324
Quote: In my C64 Debugger which I plan to release soon I added option to switch off SID emulation completely when in warp mode. This *seems* to not destroy emulation, as the ReSID cycle is synced back to CPU just a while after returning from warp. Anyway - the warp got huge speed improvement. This is a crude hack, but it seems it is acceptable in most cases. By the way I think it's high time for me to post some patches to the Vice too :-) I'll post my outcomes within next few weeks.

Your patches will be then skipped like Polish cartridges emulation developed within www.c64power.com xD
2017-05-16 14:44
dano

Registered: Jul 2004
Posts: 105
@groepaz: does cpu action have such an impact on emulation? would have thought that VIC & SID display stuff takes about 80% of the emulation power.

when talking of warp-speeds on startup:

quite some time i have the phenomenon that Vice doesn't fall back into normal mode after having (auto-)started the file given. then i have to manually un-warp emulation. can't pinpoint to when things happen like this as i 99% of my dev work just do the F7 in sublime which does compile and start vice after that.
2017-05-16 15:08
Groepaz

Registered: Dec 2001
Posts: 8120
Quote:
Your patches will be then skipped like Polish cartridges emulation developed within www.c64power.com

when the patches make test programs fail that work without the patch, then they will be rejected. obviously, i hope.
Quote:
quite some time i have the phenomenon that Vice doesn't fall back into normal mode after having (auto-)started the file given. then i have to manually un-warp emulation.

didnt see that behaviour for a long time - is that with the original kernal? any cartridges active?
2017-05-16 15:51
dano

Registered: Jul 2004
Posts: 105
Quote: Quote:
Your patches will be then skipped like Polish cartridges emulation developed within www.c64power.com

when the patches make test programs fail that work without the patch, then they will be rejected. obviously, i hope.
Quote:
quite some time i have the phenomenon that Vice doesn't fall back into normal mode after having (auto-)started the file given. then i have to manually un-warp emulation.

didnt see that behaviour for a long time - is that with the original kernal? any cartridges active?


Quote:

Quote:
quite some time i have the phenomenon that Vice doesn't fall back into normal mode after having (auto-)started the file given. then i have to manually un-warp emulation.

didnt see that behaviour for a long time - is that with the original kernal? any cartridges active?


orignal kernel, but got a retro replay or an action replay set as default freezer cartridge.

after pressing F7 the programm loads.

or nothing happens in some cases. just a normal blinking cursor then.
2017-05-16 15:52
soci

Registered: Sep 2003
Posts: 357
Quoting dano
Coming back to my problem i usually notice that the Vice Display FPS slow down the more is happening on screen. Frankly speaking screen action should not have effect on Vice Perfomance?! Having stuff like flashing/debug Bordercolors makes Vice drop in FPS like hell.


Be careful with what you wish for. I'm sure there's more than one way to achieve exactly that...
2017-05-16 15:56
Groepaz

Registered: Dec 2001
Posts: 8120
Quote:
orignal kernel, but got a retro replay or an action replay set as default freezer cartridge.
after pressing F7 the programm loads.

so, basically PEBCAK then :) to make that work reliable, use -keybuf to put a F7 keypress into keyboard buffer after reset (and after a suitable timeout). the autostart mechanism doesnt know about cartridges, nor anything that isnt the original kernal.
2017-05-16 16:15
dano

Registered: Jul 2004
Posts: 105
Quote: Quote:
orignal kernel, but got a retro replay or an action replay set as default freezer cartridge.
after pressing F7 the programm loads.

so, basically PEBCAK then :) to make that work reliable, use -keybuf to put a F7 keypress into keyboard buffer after reset (and after a suitable timeout). the autostart mechanism doesnt know about cartridges, nor anything that isnt the original kernal.


Quote:
orignal kernel, but got a retro replay or an action replay set as default freezer cartridge.
after pressing F7 the programm loads.

so, basically PEBCAK then :) to make that work reliable, use -keybuf to put a F7 keypress into keyboard buffer after reset (and after a suitable timeout). the autostart mechanism doesnt know about cartridges, nor anything that isnt the original kernal.


that pretty much NOT explains why it's working at times.

srsly, it happens, then it not happens, .... not happens, happens.. and be sure i tried various things like waiting less, waiting more. yet still if i do it 10 times the same way it can work a random number 0..10.

ofcourse it's easy to blame the user for doing <<RANDOM>> thing wrong instead of finding a solution. guess my collegues can be happy that i am not such a type of coder..

apart from the fact that i don't want to check the compile script or have "compile with f7" and "compile without f7". blabla. welcome to the world of working around quirks because the reason is not to be found or wanted to be found.. ^^
2017-05-16 16:19
Groepaz

Registered: Dec 2001
Posts: 8120
the reason is that autostart uses specific timing constraints. it works sometimes and sometimes not because the timing you press F7 with is not always the same.

and if you dont want to use the solution that actually works... ok. dont blame the emulator for it though, thats just silly =P
Previous - 1 | 2 | 3 | 4 | 5 | 6 | 7 - Next
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
copass/Leader
Croozor/CML^Arsenic
Knight Rider/Formby ..
iAN CooG/HVSC
Guests online: 49
Top Demos
1 Uncensored  (9.7)
2 Edge of Disgrace  (9.7)
3 Coma Light 13  (9.6)
4 The Shores of Reflec..  (9.6)
5 Lunatico  (9.6)
6 Comaland 100%  (9.5)
7 Incoherent Nightmare  (9.5)
8 Wonderland XII  (9.5)
9 Comaland  (9.5)
10 Wonderland XIII  (9.5)
Top onefile Demos
1 Veterans of Style  (9.5)
2 Dawnfall V1.1  (9.5)
3 Daah, Those Acid Pil..  (9.5)
4 Treu Love [reu]  (9.4)
5 Dawnfall  (9.3)
6 SidRok  (9.3)
7 F1 Evolution  (9.3)
8 One-Der  (9.2)
9 Tunnel Vision  (9.2)
10 Game of Thrones [2sid]  (9.1)
Top Groups
1 Pond  (10)
2 Booze Design  (9.4)
3 Censor Design  (9.4)
4 Oxyron  (9.4)
5 Crest  (9.3)
Top Hardware-Gurus
1 Soci  (9.9)
2 Wiesel  (9.9)
3 Grue  (9.8)
4 Zer0-X  (9.8)
5 Lemming  (9.7)

Home - Disclaimer
Copyright © No Name 2001-2017
Page generated in: 0.347 sec.