Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
  You are not logged in 
D642SD V0.1   [2020]

D642SD V0.1 Released by :
Zaindlmaier

Release Date :
18 October 2020

Type :
C64 Tool

Videosystem: PAL only

User rating:awaiting 5 votes (2 left)   See votestatistics

Credits :
Code .... Zaindlmaier

Download :
http://csdb.dk/getinternalfile.php/204969/d642sd.zip (downloads: 153)

Look for downloads on external sites:
 Pokefinder.org


User Comment
Submitted by wil on 20 October 2020
SD2IEC-Version: SD2IEC V1.0.0ATENTDEAD0-24-M1284P-SW2 Computer was a C128 in C64 mode. Videosystem PAL
The disk was previously formatted. D642SD reported that it detected both drives properly in the beginning. It could also list the disk directory. After pressing the copy function, I selected an image on the SD2IEC and then the screen went dark gray (some color as the border before). I heard the floppy rw head knocking a few times and the floppy motor went on. But then nothing more, floppy motor on, but no track change clicks were audible. And, as I said before I had Floppy as #9, because DIP switches. Thanks for looking into the problem!
User Comment
Submitted by Zaindlmaier on 20 October 2020
Uhh, the auto-detect of the dev-number "should" work, but yes, I only tested with 1541 at 8 and SD at 9.
Cause 1541 rules ;-)
I will fix that.
User Comment
Submitted by iAN CooG on 20 October 2020
why, don't you guys have a 1541 on device #8? WTF!! ;)
User Comment
Submitted by Tom-Cat on 20 October 2020
Same here. It is, however, working fine if 1541 is device #8 and SD2IEC is device #9. The other way around it just freezes when it starts the copy.
User Comment
Submitted by Zaindlmaier on 20 October 2020
What kind of SD2IEC do you use and what firmware is it?
When you send command "X?" to SD2IEC you get detailed firmware info.
Like this:
10 OPEN1,8,15,"X?":INPUT#1,A$,B$,C$,D$
20 CLOSE1:?A$B$C$D$

I guess, screencolor doesn't change when screnn is blanked?
User Comment
Submitted by wil on 20 October 2020
Unfortunately, using the program didn't work for me. I connected my VC1541-II as device 9 and had a freshly formatted disk in it. SD2IEC was device 8. The D642SD started and detected both drives well, but after selecting the copy function and the disk image to copy, the drive just shortly started and the screen went off. Drive led was off, even not blinking. Drive motor was on, but no track change clicks were audible. I tried again with a different disk, same result. I then copied with Dracopy, which was very slow, but eventually worked so I guess disk and drive were fine.
Search CSDb
Advanced
Navigate
Prev - Random - Next
Detailed Info
· Summaries (2)
· User Comments (6)
· Production Notes
Fun Stuff
· Goofs
· Hidden Parts
· Trivia
Forum
· Discuss this release
Sponsored links
Support CSDb
Help keep CSDb running:



Funding status:




About this site:
CSDb (Commodore 64 Scene Database) is a website which goal is to gather as much information and material about the scene around the commodore 64 computer - the worlds most popular home computer throughout time. Here you can find almost anything which was ever made for the commodore 64, and more is being added every day. As this website is scene related, you can mostly find demos, music and graphics made by the people who made the scene (the sceners), but you can also find a lot of the old classic games here. Try out the search box in the top right corner, or check out the CSDb main page for the latest additions.
Home - Disclaimer
Copyright © No Name 2001-2020
Page generated in: 0.079 sec.