Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
You are not logged in 
CSDb User Forums

Forums > C64 Coding > Relaunch64 - Locked until end of script?
2016-08-04 19:18

Registered: Apr 2007
Posts: 23
Relaunch64 - Locked until end of script?


I set up Relaunch64 and KickAssembler for some coding fun. I added the following compile & run-script:

R64 -iw -nowait
java -jar "D:\C64\PC Tools\KickAssembler\KickAss.jar" RSOURCEFILE
D:\WinVICE-x86\x64.exe ROUTFILE

It works fine but when executing the script, Relaunch64 is 'locked up' until WinVICE is closed. So, I can't look at the code and watch the output in WinVICE simultaneously.

Anyone who knows how to remove this locking?


... 1 post hidden. Click here to view all posts....
2016-08-04 20:32

Registered: Sep 2003
Posts: 385
Try what JackAsser said.

I saw in the help that "open" is used on OSX probably for the same reason.

The same freezing problem exists on Linux as well. But it's easy to reduce the script to call only make or a shell script, and the execute compilation and x64 backgrounded from there.

As it seems to be a recurring problem I've added "R64BG" prefix, which executes a command but ignores it's result and continues the script execution. Possibly not the best solution, but it works.


It can be reverted easily if there's a better way of course.

I'm not that much into java to be able to build a proper distributable jar for testing. So please wait for an "official" release, or try some sort of workaround like the one mentioned on top.
2016-08-04 22:36

Registered: Apr 2007
Posts: 23
Thanks JackAsser and Soci.

After JackAssers reply, I tried to build a batch-file. It worked fine in the command line (compiling and running and immediately getting back to the command line) but the batch wasn't working in Relaunch. Compiling and running: yes, but still waiting for x64 to end.

I looked at the source on GitHub and believe Relaunch keeps waiting because of the Assembler-log window. In CustomScripts.java there is a line 345:

345 pb = pb.redirectInput(ProcessBuilder.Redirect.PIPE);

I suspect the piping keeps the Assembler log window waiting because the default behaviour of the process builder should be 'nowait'.***

*** DISCLAIMER: I am no JAVA-expert or professional coder in any other computer language at all, so this might be total bullshit I am writing!

Is this prefix you added already part of the current release? If I use it, it seems the commands following it on the same line aren't executed.
2016-08-05 06:22

Registered: Sep 2003
Posts: 385
I don't think it's part of a current build as I've just made that commit before I posted ;)

Yes, it waited for x64 so it can display it's output in the error window.

The redirection left in was harmless without the actual read which is where it blocks normally. Just in case it's jumped over now as well.

The line mentioned by you is for the compiler help and is only used when "ch" is typed into the goto field. I've corrected the redirection there now (input vs. output). Strange that it worked with the wrong one as well.
2016-08-06 06:23

Registered: Oct 2014
Posts: 173
There is an option in "editor" that tells it to not wait for the script to complete. but it doesn't work on windows.

I trued the start and start /b trick, the script exits but vice doesn't show.
2016-09-03 18:37

Registered: Sep 2002
Posts: 131
Can you please try the test-release: https://github.com/sjPlot/Relaunch64/releases/tag/3.3.7-1

and see whether the "R64BG"-option works for you? I have included some examples in the help-file.
2016-09-04 05:31

Registered: Oct 2014
Posts: 173
Works Windows 10 + Vice + Tass
2016-09-04 05:34

Registered: Oct 2014
Posts: 173
Warnings are clickable, but halt execution of VICE/rest of script. Windows 10 + Tass
2016-09-04 19:57

Registered: Sep 2002
Posts: 131
I have added an option to add a second run-script, which may be used for debugging only. So the script that also runs the emulator can use the "R64BG"-option, which doesn't log warnings, and an alternative build-script for debugging can be run without starting the emulator (hence, R64BG is not needed).

New release here:
2016-09-05 06:50

Registered: Oct 2014
Posts: 173
I raised some issues on the github tracker.
2016-10-30 09:10

Registered: Sep 2002
Posts: 131
Should be fixed in the latest release (Relaunch64 V3.3.7)m using the "R64BG" option.

Quote from the help-file:

In case you have problems with the -nowait-option, so Relaunch64 is locked while an emulator is running, although you want to continue editing in Relaunch64, use R64BG as a prefix of the command line for the tool that should not block execution (mostly the command line for starting the emulator).
Previous - 1 | 2 - Next
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Users Online
Perff/No Name
icon/The Silents, Sp..
Guests online: 26
Top Demos
1 Uncensored  (9.7)
2 Edge of Disgrace  (9.7)
3 Coma Light 13  (9.6)
4 The Shores of Reflec..  (9.6)
5 Comaland 100%  (9.6)
6 We Come in Peace  (9.6)
7 Lunatico  (9.6)
8 Incoherent Nightmare  (9.5)
9 Wonderland XII  (9.5)
10 Wonderland XIII  (9.5)
Top onefile Demos
1 FMX Music Demo  (9.5)
2 Pandemoniac Part 2 o..  (9.5)
3 Daah, Those Acid Pil..  (9.5)
4 Dawnfall V1.1  (9.5)
5 Treu Love [reu]  (9.5)
6 In Memoriam BHF  (9.5)
7 Merry Xmas 2017  (9.4)
8 Dawnfall  (9.4)
9 SWiRL  (9.4)
10 Synthesis  (9.4)
Top Groups
1 Oxyron  (9.4)
2 Booze Design  (9.4)
3 Censor Design  (9.4)
4 Finnish Gold  (9.4)
5 Crest  (9.3)
Top Coders
1 Axis  (9.8)
2 Tom-Cat  (9.8)
3 Graham  (9.8)
4 Crossbow  (9.8)
5 CRT  (9.8)

Home - Disclaimer
Copyright © No Name 2001-2018
Page generated in: 0.072 sec.