Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
 Welcome to our latest new user gut10 ! (Registered 2020-01-28) You are not logged in 
CSDb User Forums


Forums > C64 Coding > Problem with running VICE on Linux ...any ideas?
2020-01-12 08:37
ZIG

Registered: Feb 2004
Posts: 20
Problem with running VICE on Linux ...any ideas?

I'm at the end of ideas so I am reaching out to the community. I have been using VICE on my rooted Chromebook for over 12 months then suddenly, after I installed C64 debugger vice stopped working. I have tried everything to get it working again and I just can't. I even recompiled from source using sdl1 flags and sdl2 flags and still no dice. It just starts and freezes when it starts to initialise the 1541. Same problem even on the 128 - just hangs before init is complete. I tried logging and debugging and get nothing that stands out. Does anyone have any novel ideas of what could be wrong or where to think about looking???

Appreciate any ideas.

Joe
2020-01-12 08:54
0xDB

Registered: Aug 2015
Posts: 27
Stabbing in the dark without any logs... but here's my thoughts anyway:

Do you have Drive sounds enabled? Is sound output configured correctly? Using PulseAudio? Asking because I had a similar problem with VICE a few years ago where it would freeze at startup because for some reason it could not output sound. When I used 'pavucontrol' while VICE was running(in its frozen state) I could re-set the Audio Sink to use for the VICE playback stream on the Playback tab which would immediately un-freeze it.

Another thing to try if that does not work is of course to delete the VICE configuration files from your home folder to reset it.
2020-01-12 09:27
ZIG

Registered: Feb 2004
Posts: 20
Tried the config delete

Love the audio sink idea. Will try.
2020-01-12 12:52
ZIG

Registered: Feb 2004
Posts: 20
That sir, was the problem! Audio sink kill fixed my issue. Source of the issue is a broken update in Crouton that screwed up audio driver (CRAS) - by changing to dummy everything went fine after that. Thanks!

Now need to wait for an update to Crouton! :(

Regards
Joe
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
Ghost/Excess
Walt/Bonzai
sailor/Triad
bugjam
Core/VPN
Jasmin68k
Viti/Hokuto Force
Shadow/Noice
JCH/Vibrants
Slummy/Spaceballs
Fabs/Hokuto Force
The Overkiller/Hokut..
Mythus/Delysid
DocSnyder
Tintin
Sh0ckTr00per/Hokuto ..
Guests online: 52
Top Demos
1 Uncensored  (9.7)
2 Coma Light 13  (9.7)
3 Edge of Disgrace  (9.7)
4 Unboxed  (9.7)
5 Comaland 100%  (9.6)
6 Lunatico  (9.6)
7 The Shores of Reflec..  (9.5)
8 Rivalry  (9.5)
9 X Marks the Spot  (9.5)
10 C=Bit 18  (9.5)
Top onefile Demos
1 Tribute to Ben - Las..  (9.8)
2 Gumbo Revised  (9.6)
3 Crystal Gazer  (9.6)
4 Smile to the Sky  (9.5)
5 Dawnfall V1.1  (9.5)
6 Daah, Those Acid Pil..  (9.5)
7 Instinct  (9.5)
8 Innervasion  (9.5)
9 Merry Krampus  (9.5)
10 Pandemoniac Part 5 o..  (9.5)
Top Groups
1 Oxyron  (9.4)
2 Booze Design  (9.4)
3 Fossil  (9.4)
4 PriorArt  (9.4)
5 Censor Design  (9.4)
Top Original Suppliers
1 hedning  (9.8)
2 Derbyshire Ram  (9.3)
3 Irata  (9.3)
4 Jazzcat  (9.1)
5 Fungus  (9.0)

Home - Disclaimer
Copyright © No Name 2001-2020
Page generated in: 0.03 sec.