Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
You are not logged in 
CSDb User Forums


Forums > C64 Coding > Drive Code C128D N0SD0S Scanner bug.
2007-05-30 15:08
6R6

Registered: Feb 2002
Posts: 228
Drive Code C128D N0SD0S Scanner bug.

Recently Nostalgia released Legacy of the Ancients.
Legacy of the Ancients +8DIR

The program used to scan the IFFL file refuse to
work on a C128D. I got this error report from someone
in USA, so I did a test on my own C128D.

What happens is:
Installer searches for the iffl file,
then it locates track+sector of the iffl file.
At this point this text is displayed on screen.

N0SD0S V1.2

SCANNING

73, CBM DOS V3.0 1571,00,00

Then scanner get installed in the 1571 drive. Scanner now
searches the IFFL file and you can hear the drive is working
as it makes a click for each track it moves to.
But then at the end of scanning everything freezes,
drive is spinning forever and the led is on.

I tried the same game disk on my c64+1541 and it
works fine. I tried not messing with the $1c07 timer.
I tried with and without fastload cartridge on my c128D.
But I get the same bug each time. Some have said i Have a bad VIC chip, but the VSP scroller in the n0s intro works fine for me.

I am not sure if its the C128D or the disk drive that is causing the problem. I wonder if anyone of you can help
me by verifying if it works or not on these setups:

1) C128D.
2) C128D but run the game from a external 1541(II) drive.
3) C128 + 1571
4) C128 + 1541(II)
5) C64 + 1571

Please post your report here.
Also, if you have any other suggestions to what
the problem might be please post here.
Thanks!
 
... 21 posts hidden. Click here to view all posts....
 
2007-07-05 02:28
Krill

Registered: Apr 2002
Posts: 1235
Yes, C128D is a pain in the ass. I fixed and re-fixed my loader several times for it.
2007-07-05 04:59
Oswald

Registered: Apr 2002
Posts: 4401
krill, your earlier versions all worked fine on my 128dcr.
2007-07-05 06:26
Mace

Registered: May 2002
Posts: 1780
Quote:
@Mace:
Can you test LOTA with a normal C128 + various drives as device #9 and see if it hangs ?

Okidoki, will do so tonight.
2007-07-05 10:52
Trurl

Registered: Mar 2002
Posts: 39
I dug out my flat C128 and tested LOTA with 1541-II. It worked as drive #8 but as #9, #10 and #11 it got to the EOA screen and jammed there.

EDIT: I just tested it with my breadbox+1541-II and it jams just the same as #9.
2007-08-09 00:29
6R6

Registered: Feb 2002
Posts: 228
Hello again.


I have dug my nose into this, and done some checking on the N0sD0s 1.2 bug where we have a 1541-II/1571 drive as device #9 on the serial bus.
The first bug that happens is that the installer
stops at the n0sd0s splash screen where "scanning" is displayed.
This has been partially solved.

The second bug that happens is more interesting:
To explain the bug I have done 5 tests to show
what happens. As for equipment setup I
use a C64 with RR + RRnet, a 1541 as device #8 and
a 1541-II as device #9. (Daisy chain connection)


Test 1: C64 - 1541 (#8) - 1541-II (#9)
--------------------------------------
If I run a N0sd0s game from #9 I only get crap data when loading, sometimes i get bytes that are correct. (Mostly $aa,$a0,$a3.)

Test 2: C64 - 1541 (turned off) - 1541-II (#9)
----------------------------------------------
If I run N0sd0s game from #9 I only get crap data when loading, sometimes i get bytes that are correct. (Mostly $aa,$a0,$a3.)

Test 3: C64 - 1541 (turned off) - 1541-II (#8)
----------------------------------------------
If I run a N0sd0s game from the 1541-II drive, with dip switches set to device #8, it works fine.

Test 4: C64 - 1541-II (#9)
---------------------------
In this test i removed the 1541 drive, and connected the
C64 directly to the 1541-II as device #9.
And it doesnt work, i get a lot of crap data.

But if I turn the dip switches to device #8 it works fine
again.

Test 5: C64 - 1541 (#8) - 1581 (#9) - CMD FD 4000 (#10)
-------------------------------------------------------
In this test I have all devices turned on.
The game works fine from any of the devices.


I don't understand why this happens.
What happens in the 1541-II drive when I flip the dip switches to device position #9 ?
(I also tried setting the 1541-II to #10 and #11 and it gave the same error.)
Does the dip switching corrupt the $1800 registers when I use $dd02.
Because I am using $dd02 in the code.

The C64 side of the handshake uses $dd02 to toggle the bits in $dd00 when sending
bytes to the disk drive. The get byte routine doesnt use $dd02 registers.
I'm suspecting it has to do with $dd02.


Our old n0sd0s 1.0 works fine:
Conan +3D
Check that game from any device number.
C64 code here only uses $dd00.

Maybe Doc Bacardi, Ninja, Krill, Graham, Lasse, HCL, or some other skilled
drive coder can give me a explanation for this behaviour ?
Thanks :)
2007-08-09 05:27
TNT
Account closed

Registered: Oct 2004
Posts: 189
Device number setting changes bits 5 & 6 at $1800. If the loader assumes they are both zero (as thay are with device #8) then it will fail with other device numbers.
2007-08-09 06:47
6R6

Registered: Feb 2002
Posts: 228
Oh shit! I have forgotten to check that.

2007-08-09 17:24
6R6

Registered: Feb 2002
Posts: 228
Ah, excellent. Now it works from device #9 again.
Thanks TNT! :)
I didnt think about the device number was hard wired to the $1800 register.
2007-08-10 11:48
TNT
Account closed

Registered: Oct 2004
Posts: 189
An additional note: if you need to do some runtime modifications to the drive transfer code depending on device number, it's better to do it in drive using the value from $1800 instead of drive number. That way the loader will work even if drive number was changed with "m-w".
2007-09-12 07:03
6R6

Registered: Feb 2002
Posts: 228
All bugs found and fixed. Thanks to all for help. :)

Previous - 1 | 2 | 3 | 4 - Next
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
blendo75
goerp
simun9/CMS
Scooby/G★P/Light
Guests online: 53
Top Demos
1 Unboxed  (9.7)
2 Uncensored  (9.7)
3 Coma Light 13  (9.7)
4 Edge of Disgrace  (9.6)
5 Comaland 100%  (9.6)
6 The Shores of Reflec..  (9.6)
7 Lunatico  (9.6)
8 X Marks the Spot  (9.5)
9 Wonderland XII  (9.5)
10 OMG Got Balls!  (9.5)
Top onefile Demos
1 Smile to the Sky  (9.5)
2 Instinct  (9.5)
3 Daah, Those Acid Pil..  (9.5)
4 Dawnfall V1.1  (9.4)
5 Pandemoniac Part 2 o..  (9.4)
6 Crystal Gazer  (9.4)
7 Rewind  (9.4)
8 Bad Boy  (9.4)
9 Official X2018 Report  (9.4)
10 Party Horse  (9.4)
Top Groups
1 Fossil  (9.7)
2 PriorArt  (9.6)
3 Oxyron  (9.4)
4 Booze Design  (9.4)
5 Censor Design  (9.3)
Top Diskmag Editors
1 hedning  (9.8)
2 Jazzcat  (9.5)
3 Newscopy  (9.4)
4 Peter  (9.3)
5 A Life in Hell  (9.2)

Home - Disclaimer
Copyright © No Name 2001-2019
Page generated in: 0.065 sec.