Log inRegister an accountBrowse CSDbHelp & documentationFacts & StatisticsThe forumsAvailable RSS-feeds on CSDbSupport CSDb Commodore 64 Scene Database
You are not logged in 
CSDb User Forums


Forums > CSDb Discussions > WinVice & Windows 10 error
2016-04-21 12:23
The Phantom

Registered: Jan 2004
Posts: 354
WinVice & Windows 10 error

OK. I've dealt with this for a week or two and it's time to see if a solution is available.

WinVice 2.4 (win64 x64 mingw)

Anytime I double click a .d64, I get this error:

VICE Error!
Cannot startup logging system.

I hit enter (or click OK) and that is that. I haven't had any issues with Vice, just this silly error.

Any way to fix this? I can deal with hitting enter, but would rather Vice just boot up without my having to do so.
 
... 30 posts hidden. Click here to view all posts....
 
2016-12-30 17:32
Compyx

Registered: Jan 2005
Posts: 416
Can't produce this. When I select SID settings, nothing weird happens and I can quit VICE gracefully:

Cannot open winio32.dll, trying direct PCI I/O access.
Cannot use direct PCI I/O access on Windows NT/2000/Server/XP/Vista/7/8/10.
Detecting dll assisted PardSIDs.
Cannot open inpout32.dll.
Detecting direct I/O PardSIDs.
Cannot use direct I/O on Windows NT/2000/Server/XP/Vista/7/8/10.
Detecting ISA SSI2001 boards.
Cannot open inpout32.dll, trying direct ISA I/O access.
Cannot use direct I/O access on Windows NT/2000/Server/XP/Vista/7/8/10.
Sound: Closing device `dx'
Sound: Opened device `dx', speed 44100Hz, fragment size 2.9ms, buffer size 101ms
reSID: MOS8580, filter on, sampling rate 44100Hz - resampling, pass to 19845Hz

Exiting...
Sound: Closing device `dx'


Perhaps this has something to with parallel ports, my VM doesn't expose those.
Looks like another job for our Windows maintainer.
2019-01-08 23:35
bepp

Registered: Jun 2010
Posts: 249
Necro-posting to this old thread if someone finds it on google (like I did).

I just started to get the "Cannot startup logging system" in Win10. It turns out I had a faulty entry in the setting for LogFileName, pointing to a folder/file that did not exist. Simply removing this line from vice.ini (which is stored in %appdata%\vice\3.1\vice.ini) did the trick for me. Maybe it can help someone that stumbles upon this.
2019-01-09 01:04
Compyx

Registered: Jan 2005
Posts: 416
For VICE 3.3+ the vice config dir is in %appdata%/vice, we removed the "$major.$minor" subdir. So on my box it's C:\users\comp*x\appdata\roaming\vice.

The 'roaming' bit is currently hardcoded, if someone can explain why it's sometimes 'roaming' and sometimes 'local', or even 'LocalLow', our Windows maintainer would be much obliged :)
2019-01-09 07:27
soci

Registered: Sep 2003
Posts: 418
Use SHGetFolderPath with CSIDL_APPDATA instead of hardcoding the path within the profile directory. Or even SHGetKnownFolderPath if supporting XP is not a concern.
2019-01-09 11:22
Stryyker

Registered: Dec 2001
Posts: 463
In relation to error: lib_stralloc(NULL) not allowed

Some of the recent issues with Windows 10 can be because of winpcap being installed and not detecting network interfaces. The same can be witnessed in Wireshark. Uninstall winpcap and use npcap instead. Alternatively a vice build without ethernet
2019-01-10 17:33
Compyx

Registered: Jan 2005
Posts: 416
Quoting soci
Use SHGetFolderPath with CSIDL_APPDATA instead of hardcoding the path within the profile directory. Or even SHGetKnownFolderPath if supporting XP is not a concern.


Thanks, will check out these functions.
2019-01-10 17:48
Compyx

Registered: Jan 2005
Posts: 416
Quoting Stryyker
In relation to error: lib_stralloc(NULL) not allowed

Some of the recent issues with Windows 10 can be because of winpcap being installed and not detecting network interfaces. The same can be witnessed in Wireshark. Uninstall winpcap and use npcap instead. Alternatively a vice build without ethernet


I had some suspicions the lib_stralloc(NULL) might be coming from a failure to enumerate network adapters via winpcap.
Of course on my box any Windows update doesn't trigger any pcap errors or UAC prompts, so it's a little hard to debug on my end.
2019-01-10 19:35
Stryyker

Registered: Dec 2001
Posts: 463
I recently done a test in a fresh VM of Windows 10, 1809 as a standard users and r35878 seemed to work fine. No need to start as admin or any UAC issues.
2019-01-10 21:26
Compyx

Registered: Jan 2005
Posts: 416
Nice, and I assume this was with npcap, disabling the tick mark in the installer for 'require admin' and enabling the tick mark for 'wpcap API compatibility'?

That worked for me at least.

If so, we need to update our docs to tell people to use npcap and not wpcap.
2019-01-11 11:04
Stryyker

Registered: Dec 2001
Posts: 463
no npcap or wincap installed. I guess the VM exposes the NICs a little differently.

In a 2nd native install on a system with Realtek with Windows 10, 1809 it ran fine - no need for admin.

The 1st native install was on a system with Intel NIC using 23.5 Intel ProSet drivers using the new Windows 10 driver model.
Previous - 1 | 2 | 3 | 4 - Next
RefreshSubscribe to this thread:

You need to be logged in to post in the forum.

Search the forum:
Search   for   in  
All times are CET.
Search CSDb
Advanced
Users Online
blendo75
Powerslave/Triad
Optic Freeze/G★P
Core/(VPN)
Guests online: 25
Top Demos
1 Uncensored  (9.7)
2 Unboxed  (9.7)
3 Comaland 100%  (9.7)
4 Edge of Disgrace  (9.7)
5 Coma Light 13  (9.6)
6 The Shores of Reflec..  (9.6)
7 Wonderland XII  (9.6)
8 Lunatico  (9.6)
9 C=Bit 18  (9.6)
10 Incoherent Nightmare  (9.5)
Top onefile Demos
1 Smile to the Sky  (9.7)
2 Daah, Those Acid Pil..  (9.5)
3 FMX Music Demo  (9.5)
4 Arok 20 Invitation  (9.5)
5 Pandemoniac Part 2 o..  (9.5)
6 Dawnfall V1.1  (9.4)
7 Crystal Gazer  (9.4)
8 Merry Xmas 2017  (9.4)
9 Rewind  (9.4)
10 Party Horse  (9.4)
Top Groups
1 PriorArt  (9.8)
2 Oxyron  (9.4)
3 Performers  (9.4)
4 Booze Design  (9.4)
5 Censor Design  (9.3)
Top Diskmag Editors
1 Jazzcat  (9.4)
2 Newscopy  (9.4)
3 Peter  (9.3)
4 A Life in Hell  (9.2)
5 Remix  (9.2)

Home - Disclaimer
Copyright © No Name 2001-2019
Page generated in: 0.053 sec.